CVE-2024-9313 PAM module may allow accessing with the credentials of another user

High 8.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-9313?

CVE-2024-9313 is a high-severity vulnerability in Canonical Ltd. Authd, published on 3 Oct 2024.

Official description

Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.

Which versions are affected by CVE-2024-9313?

5 open source packages ship an affected version, including github.com/ubuntu/authd. It affects 1 product.

PackageAffectedFixed in
github.com/ubuntu/authd GoAll versions0.0.0-20240930103526-63e527496b01
github.com/ubuntu/authd GoAll versions0.0.0-20240930103526-63e527496b01
github.com/ubuntu/authd GoAll versions0.3.5
github.com/ubuntu/authd GoFrom 0.1.00.3.5
github.com/ubuntu/authd GoFrom 0.1.00.3.5

Products include Canonical Authd.

How do I fix CVE-2024-9313?

Upgrade github.com/ubuntu/authd to a fixed version for your release line: 0.0.0-20240930103526-63e527496b01 or 0.3.5.

Is CVE-2024-9313 being exploited?

There is no known exploitation of CVE-2024-9313 in the wild and no public exploit code.

Sources

Also known as GHSA-x5q3-c8rm-w787, GO-2024-3181.

Is CVE-2024-9313 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free