# CVE-2024-9313: PAM module may allow accessing with the credentials of another user


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Oct 2024
- **Updated:** 22 Nov 2024
- **Also known as:** GHSA-x5q3-c8rm-w787, GO-2024-3181

## What is CVE-2024-9313?

CVE-2024-9313 is a high-severity vulnerability in Canonical Ltd. Authd, published on 3 Oct 2024. 

### Official description

Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.

## Which versions are affected by CVE-2024-9313?

5 open source packages ship an affected version, including github.com/ubuntu/authd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ubuntu/authd` | Go | All versions | 0.0.0-20240930103526-63e527496b01 |
| `github.com/ubuntu/authd` | Go | All versions | 0.0.0-20240930103526-63e527496b01 |
| `github.com/ubuntu/authd` | Go | All versions | 0.3.5 |
| `github.com/ubuntu/authd` | Go | From 0.1.0 | 0.3.5 |
| `github.com/ubuntu/authd` | Go | From 0.1.0 | 0.3.5 |

Products: Canonical Authd.

## How do I fix CVE-2024-9313?

Upgrade github.com/ubuntu/authd to a fixed version for your release line: 0.0.0-20240930103526-63e527496b01 or 0.3.5.

## Is CVE-2024-9313 being exploited?

There is no known exploitation of CVE-2024-9313 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ltd. Authd

- [CVE-2025-5689](https://insights.sbomify.com/CVE-2025-5689/): Improper Permission Management in SSH Session Handling (high 8.5)
- [CVE-2024-9312](https://insights.sbomify.com/CVE-2024-9312/): Authd allows attacker-controlled usernames to yield controllable UIDs (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9313 and fix it if it is affected.

What it is: CVE-2024-9313 is a high-severity vulnerability in Canonical Ltd. Authd, published on 3 Oct 2024. 
Exploitation: There is no known exploitation of CVE-2024-9313 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.0.0-20240930103526-63e527496b01
- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.0.0-20240930103526-63e527496b01
- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.3.5
- github.com/ubuntu/authd (Go): affected from 0.1.0; fixed in 0.3.5
- github.com/ubuntu/authd (Go): affected from 0.1.0; fixed in 0.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9313/ (Markdown: https://insights.sbomify.com/CVE-2024-9313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9313
- OSV: https://osv.dev/vulnerability/CVE-2024-9313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9313/
Summaries are generated and may contain mistakes; the official description above is the record.
