# CVE-2024-9340: Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml

> Unauthenticated attackers can cause a denial of service by sending malformed multipart requests that trigger an infinite loop in ZenML.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Jul 2025
- **Also known as:** GHSA-6gmf-2369-c76c, PYSEC-2025-57

## What is CVE-2024-9340?

CVE-2024-9340 is a high-severity denial of service vulnerability in zenml-io/zenml, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Denial of Service (DoS) vulnerability in zenml-io/zenml version 0.66.0 allows unauthenticated attackers to cause excessive resource consumption by sending malformed multipart requests with arbitrary characters appended to the end of multipart boundaries. This flaw in the multipart request boundary processing mechanism leads to an infinite loop, resulting in a complete denial of service for all users. Affected endpoints include `/api/v1/login` and `/api/v1/device_authorization`.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-9340?

3 open source packages ship an affected version, including zenml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenml` | PyPI | All versions | 0.68.0 |
| `zenml` | PyPI | All versions | 0.68.0 |
| `zenml` | PyPI | All versions | 0.68.0 |

Products: Zenml Zenml.

## How do I fix CVE-2024-9340?

Upgrade zenml to 0.68.0 or later.

## Is CVE-2024-9340 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9340 exists.

## Other vulnerabilities in zenml-io/zenml

- [CVE-2024-2083](https://insights.sbomify.com/CVE-2024-2083/): Directory Traversal in zenml-io/zenml (critical 9.9)
- [CVE-2024-28424](https://insights.sbomify.com/CVE-2024-28424/): Code injection in n/a (high 8.8)
- [CVE-2024-25723](https://insights.sbomify.com/CVE-2024-25723/): ZenML Server Remote Privilege Escalation Vulnerability (high 8.8)
- [CVE-2024-2035](https://insights.sbomify.com/CVE-2024-2035/): Improper Authorization in zenml-io/zenml (medium 6.5)
- [CVE-2025-8406](https://insights.sbomify.com/CVE-2025-8406/): Path Traversal in zenml-io/zenml (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9340 and fix it if it is affected.

What it is: CVE-2024-9340 is a high-severity denial of service vulnerability in zenml-io/zenml, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9340 exists.

Affected packages and fixed versions:
- zenml (PyPI): affected all versions; fixed in 0.68.0
- zenml (PyPI): affected all versions; fixed in 0.68.0
- zenml (PyPI): affected all versions; fixed in 0.68.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9340/ (Markdown: https://insights.sbomify.com/CVE-2024-9340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9340
- OSV: https://osv.dev/vulnerability/CVE-2024-9340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9340/
Summaries are generated and may contain mistakes; the official description above is the record.
