CVE-2024-9347 The Ultimate WordPress Toolkit – WP Extended <= 3.0.9 - Reflected Cross-Site Scripting

Medium 6.1 Published Updated

Unauthenticated attackers can inject arbitrary scripts via the wpext-export parameter, requiring user interaction to execute.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-9347?

CVE-2024-9347 is a medium-severity cross-site scripting vulnerability in wpextended The Ultimate WordPress Toolkit – WP Extended, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wpext-export' parameter in all versions up to, and including, 3.0.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Please note this fix was reverted in version 3.0.11 and later fixed again in version 3.0.13.

Weakness: CWE-79

Which versions are affected by CVE-2024-9347?

It affects 1 product.

Products include Wpextended Wp Extended.

How do I fix CVE-2024-9347?

No fix has been published for CVE-2024-9347 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-9347 being exploited?

There is no known exploitation of CVE-2024-9347 in the wild and no public exploit code.

Sources

Also known as GHSA-53mg-f6w7-m2qc.

Is CVE-2024-9347 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free