{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-9347 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-9347 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-9347 is a medium-severity cross-site scripting vulnerability in wpextended The Ultimate WordPress Toolkit – WP Extended, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-9347 and fix it if it is affected.\n\nWhat it is: CVE-2024-9347 is a medium-severity cross-site scripting vulnerability in wpextended The Ultimate WordPress Toolkit – WP Extended, published on 17 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-9347 in the wild and no public exploit code.\n\nAffected product: wpextended The Ultimate WordPress Toolkit – WP Extended. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9347/ (Markdown: https://insights.sbomify.com/CVE-2024-9347/index.md)","id":"CVE-2024-9347","markdown":"https://insights.sbomify.com/CVE-2024-9347/index.md","name":"CVE-2024-9347","record":{"aliases":["GHSA-53mg-f6w7-m2qc"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can inject arbitrary scripts via the wpext-export parameter, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wp_extended","vendor":"wpextended"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wpext-export' parameter in all versions up to, and including, 3.0.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Please note this fix was reverted in version 3.0.11 and later fixed again in version 3.0.13.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"The Ultimate WordPress Toolkit – WP Extended \u003c= 3.0.9 - Reflected Cross-Site Scripting","id":"CVE-2024-9347","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"Docker Desktop before v4.34.3 allows RCE via unsanitized GitHub source link in Build view","id":"CVE-2024-9348"},"packages":[],"prev":{"headline":"Embed videos and respect privacy \u003c= 1.2 - Reflected Cross-Site Scripting","id":"CVE-2024-9346"},"products":["The Ultimate WordPress Toolkit – WP Extended"],"published":"2024-10-17","related":[{"cvss_score":8.8,"headline":"The Ultimate WordPress Toolkit – WP Extended \u003c= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update","id":"CVE-2024-8102","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":8.8,"headline":"Path traversal in The Ultimate WordPress Toolkit – WP Extended","id":"CVE-2024-8104","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":7.4,"headline":"Missing authorization in The Ultimate WordPress Toolkit – WP Extended","id":"CVE-2024-11916","kev_date_added":null,"published":"2025-01-08"},{"cvss_score":7.1,"headline":"WordPress WP Extended plugin \u003c= 2.4.7 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-37259","kev_date_added":null,"published":"2024-07-22"},{"cvss_score":6.5,"headline":"The Ultimate WordPress Toolkit – WP Extended \u003c= 3.0.8 - Authenticated (Subscriber+) Sensitive Information Exposure","id":"CVE-2024-8106","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":6.1,"headline":"The Ultimate WordPress Toolkit – WP Extended \u003c= 3.0.8 - Reflected Cross-Site Scripting via selected_option","id":"CVE-2024-8117","kev_date_added":null,"published":"2024-09-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["wpextended"]},"summary":"Unauthenticated attackers can inject arbitrary scripts via the wpext-export parameter, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2024-9347/"}