{"answers":{"affected":"2 open source packages ship an affected version, including slim-select. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9440 exists.","fix":"Upgrade slim-select to 2.9.2 or later.","what":"CVE-2024-9440 is a medium-severity cross-site scripting vulnerability in slimselectjs:slim_select, published on 2 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-9440 and fix it if it is affected.\n\nWhat it is: CVE-2024-9440 is a medium-severity cross-site scripting vulnerability in slimselectjs:slim_select, published on 2 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9440 exists.\n\nAffected packages and fixed versions:\n- slim-select (npm): affected from 2.0.0; fixed in 2.9.2\n- slim-select (npm): affected from 2.0.0; fixed in 2.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9440/ (Markdown: https://insights.sbomify.com/CVE-2024-9440/index.md)","id":"CVE-2024-9440","markdown":"https://insights.sbomify.com/CVE-2024-9440/index.md","name":"CVE-2024-9440","record":{"aliases":["GHSA-qvqv-mcxr-x8qw"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript UI library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via unsanitized input in Slim Select's createOption function, affecting applications using this library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"slim_select","vendor":"slimselectjs"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to dynamically generate lists using unsanitized user-provided input may be vulnerable to cross-site scripting, resulting in attacker executed JavaScript. At this time, no patch is available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Slim Select 2.0 createOption \"text\" XSS","id":"CVE-2024-9440","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Linear eMerge e3-Series Forgot Password Command Injection","id":"CVE-2024-9441"},"packages":[{"ecosystem":"npm","fixed":["2.9.2"],"introduced":["2.0.0"],"last_affected":[],"package":"slim-select","purl":null,"source":"GHSA-qvqv-mcxr-x8qw"},{"ecosystem":"npm","fixed":["2.9.2"],"introduced":["2.0.0"],"last_affected":[],"package":"slim-select","purl":"pkg:npm/slim-select","source":"GHSA-qvqv-mcxr-x8qw"}],"prev":{"headline":"Remote Code Execution in transformeroptimus/superagi","id":"CVE-2024-9439"},"products":["slimselectjs:slim_select"],"published":"2024-10-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["slimselectjs"]},"summary":"Attackers can execute arbitrary JavaScript via unsanitized input in Slim Select's createOption function, affecting applications using this library.","url":"https://insights.sbomify.com/CVE-2024-9440/"}