CVE-2024-9487 Auth bypass in Enterprise Server

Critical 9.5 Published Updated

Attackers can bypass SAML SSO authentication to gain unauthorized access and provision users if encrypted assertions are enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-9487?

CVE-2024-9487 is a critical authentication bypass vulnerability in Github Enterprise Server, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An improper verification of cryptographic signature vulnerability was identified in GitHub Enterprise Server that allowed SAML SSO authentication to be bypassed resulting in unauthorized provisioning of users and access to the instance. Exploitation required the encrypted assertions feature to be enabled, and the attacker would require direct network access as well as a signed SAML response or metadata document. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.15 and was fixed in versions 3.11.16, 3.12.10, 3.13.5, and 3.14.2. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-347

Which versions are affected by CVE-2024-9487?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2024-9487?

No fix has been published for CVE-2024-9487 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-9487 being exploited?

There is no known exploitation of CVE-2024-9487 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-g83h-4727-5rpv.

Is CVE-2024-9487 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free