# CVE-2024-9520: UserPlus <= 2.0 - Missing Authorization via Multiple Functions

> Authenticated subscribers can modify or delete user meta and plugin options due to missing capability checks in the UserPlus WordPress plugin.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Oct 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-472x-3g5g-c8wv

## What is CVE-2024-9520?

CVE-2024-9520 is a medium-severity missing authorization vulnerability in User registration & user profile – UserPlus, published on 10 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The UserPlus plugin for WordPress is vulnerable to unauthorized access, modification, and loss of data due to a missing capability check on multiple functions in all versions up to, and including, 2.0. This makes it possible for authenticated attackers with subscriber-level permissions or above, to add, modify, or delete user meta and plugin options.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-9520?

It affects 1 product.


Products: Wpuserplus Userplus.

## How do I fix CVE-2024-9520?

No fix has been published for CVE-2024-9520 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-9520 being exploited?

There is no known exploitation of CVE-2024-9520 in the wild and no public exploit code.

## Other vulnerabilities in User registration & user profile – UserPlus

- [CVE-2024-9518](https://insights.sbomify.com/CVE-2024-9518/): UserPlus <= 2.0 - Unauthenticated Privilege Escalation (critical 9.8)
- [CVE-2023-0824](https://insights.sbomify.com/CVE-2023-0824/): UserPlus <= 2.0 - Stored XSS via CSRF (high 7.4)
- [CVE-2024-9519](https://insights.sbomify.com/CVE-2024-9519/): UserPlus <= 2.0 - Authenticated (Editor+) Registration Form Update to Privilege Escalation (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9520 and fix it if it is affected.

What it is: CVE-2024-9520 is a medium-severity missing authorization vulnerability in User registration & user profile – UserPlus, published on 10 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-9520 in the wild and no public exploit code.

Affected product: User registration & user profile – UserPlus. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9520/ (Markdown: https://insights.sbomify.com/CVE-2024-9520/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9520
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9520
- OSV: https://osv.dev/vulnerability/CVE-2024-9520

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9520/
Summaries are generated and may contain mistakes; the official description above is the record.
