CVE-2024-9596 Inclusion of Sensitive Information in Source Code in GitLab

Low 3.7 Published Updated

Unauthenticated attackers can determine the GitLab version number, aiding targeted attacks against specific vulnerabilities.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-9596?

CVE-2024-9596 is a low-severity vulnerability in Gitlab Gitlab, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 16.6 prior to 17.2.9, from 17.3 prior to 17.3.5, and from 17.4 prior to 17.4.2. It was possible for an unauthenticated attacker to determine the GitLab version number for a GitLab instance.

Weakness: CWE-540

Which versions are affected by CVE-2024-9596?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.6.017.2.9, 17.3.5, 17.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-9596?

Upgrade gitlab to a fixed version for your release line: 17.2.9, 17.3.5 or 17.4.2.

Is CVE-2024-9596 being exploited?

There is no known exploitation of CVE-2024-9596 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-9596, GHSA-r4v6-vp2q-qh25.

Is CVE-2024-9596 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free