# CVE-2024-9596: Inclusion of Sensitive Information in Source Code in GitLab

> Unauthenticated attackers can determine the GitLab version number, aiding targeted attacks against specific vulnerabilities.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 10 Oct 2024
- **Also known as:** BIT-gitlab-2024-9596, GHSA-r4v6-vp2q-qh25

## What is CVE-2024-9596?

CVE-2024-9596 is a low-severity vulnerability in Gitlab Gitlab, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue has been discovered in GitLab EE affecting all versions starting from 16.6 prior to 17.2.9, from 17.3 prior to 17.3.5, and from 17.4 prior to 17.4.2. It was possible for an unauthenticated attacker to determine the GitLab version number for a GitLab instance.

Weakness: CWE-540 (Inclusion of Sensitive Information in Source Code)

## Which versions are affected by CVE-2024-9596?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.6.0 | 17.2.9, 17.3.5, 17.4.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-9596?

Upgrade gitlab to a fixed version for your release line: 17.2.9, 17.3.5 or 17.4.2.

## Is CVE-2024-9596 being exploited?

There is no known exploitation of CVE-2024-9596 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9596 and fix it if it is affected.

What it is: CVE-2024-9596 is a low-severity vulnerability in Gitlab Gitlab, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-9596 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.6.0; fixed in 17.2.9, 17.3.5, 17.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9596/ (Markdown: https://insights.sbomify.com/CVE-2024-9596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9596
- OSV: https://osv.dev/vulnerability/CVE-2024-9596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9596/
Summaries are generated and may contain mistakes; the official description above is the record.
