# CVE-2024-9606: Improper Output Neutralization for Logs in berriai/litellm

> Attackers can read sensitive API keys from logs because the masking logic only hides the first five characters of the key.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-g5pg-73fc-hjwq, PYSEC-2026-1548

## What is CVE-2024-9606?

CVE-2024-9606 is a high-severity vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In berriai/litellm before version 1.44.12, the `litellm/litellm_core_utils/litellm_logging.py` file contains a vulnerability where the API key masking code only masks the first 5 characters of the key. This results in the leakage of almost the entire API key in the logs, exposing a significant amount of the secret key. The issue affects version v1.44.9.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2024-9606?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.44.12 |
| `litellm` | PyPI | All versions | 1.44.12 |
| `litellm` | PyPI | All versions | 1.44.12 |

Products: Litellm Litellm.

## How do I fix CVE-2024-9606?

Upgrade litellm to 1.44.12 or later.

## Is CVE-2024-9606 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9606 exists.

## Other vulnerabilities in berriai/litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9606 and fix it if it is affected.

What it is: CVE-2024-9606 is a high-severity vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9606 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.44.12
- litellm (PyPI): affected all versions; fixed in 1.44.12
- litellm (PyPI): affected all versions; fixed in 1.44.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9606/ (Markdown: https://insights.sbomify.com/CVE-2024-9606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9606
- OSV: https://osv.dev/vulnerability/CVE-2024-9606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9606/
Summaries are generated and may contain mistakes; the official description above is the record.
