# CVE-2024-9621: Io.quarkiverse.cxf:quarkus-cxf: quarkus cxf may log user password and secret to application log

> Attackers with log access can view sensitive passwords and secrets in Quarkus CXF application logs due to improper masking.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2024
- **Updated:** 8 Aug 2026
- **Also known as:** GHSA-jqh2-ch7p-xwxh

## What is CVE-2024-9621?

CVE-2024-9621 is a medium-severity vulnerability in Red Hat Build of Apache Camel 4.4 for Quarkus 3.8, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in Quarkus CXF. Passwords and other secrets may appear in the  application log in spite of the user configuring them to be hidden. This issue requires some special configuration to be vulnerable, such as SOAP logging enabled, application set client, and endpoint logging properties, and the attacker must have access to the application log.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-9621?

2 open source packages ship an affected version, including io.quarkiverse.cxf:quarkus-cxf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.quarkiverse.cxf:quarkus-cxf` | Maven | All versions | 3.15.2 |
| `io.quarkiverse.cxf:quarkus-cxf` | Maven | All versions | 3.15.2 |

## How do I fix CVE-2024-9621?

Upgrade io.quarkiverse.cxf:quarkus-cxf to 3.15.2 or later.

## Is CVE-2024-9621 being exploited?

There is no known exploitation of CVE-2024-9621 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9621 and fix it if it is affected.

What it is: CVE-2024-9621 is a medium-severity vulnerability in Red Hat Build of Apache Camel 4.4 for Quarkus 3.8, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-9621 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.quarkiverse.cxf:quarkus-cxf (Maven): affected all versions; fixed in 3.15.2
- io.quarkiverse.cxf:quarkus-cxf (Maven): affected all versions; fixed in 3.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9621/ (Markdown: https://insights.sbomify.com/CVE-2024-9621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9621
- OSV: https://osv.dev/vulnerability/CVE-2024-9621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9621/
Summaries are generated and may contain mistakes; the official description above is the record.
