CVE-2024-9623 Incorrect Authorization in GitLab

Medium 4.9 Published Updated

Attackers with deploy keys can push code to archived repositories, bypassing intended write restrictions in GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-9623?

CVE-2024-9623 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 10 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.16 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows deploy keys to push to an archived repository.

Weakness: CWE-863

Which versions are affected by CVE-2024-9623?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.16.017.2.9, 17.3.5, 17.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-9623?

Upgrade gitlab to a fixed version for your release line: 17.2.9, 17.3.5 or 17.4.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-9623 being exploited?

There is no known exploitation of CVE-2024-9623 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-9623, GHSA-m8gr-q643-3q88, UBUNTU-CVE-2024-9623.

Is CVE-2024-9623 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free