# CVE-2024-9623: Incorrect Authorization in GitLab

> Attackers with deploy keys can push code to archived repositories, bypassing intended write restrictions in GitLab.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 10 Oct 2024
- **Also known as:** BIT-gitlab-2024-9623, GHSA-m8gr-q643-3q88, UBUNTU-CVE-2024-9623

## What is CVE-2024-9623?

CVE-2024-9623 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 10 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.16 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows deploy keys to push to an archived repository.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-9623?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 8.16.0 | 17.2.9, 17.3.5, 17.4.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-9623?

Upgrade gitlab to a fixed version for your release line: 17.2.9, 17.3.5 or 17.4.2.

## Is CVE-2024-9623 being exploited?

There is no known exploitation of CVE-2024-9623 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9623 and fix it if it is affected.

What it is: CVE-2024-9623 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 10 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-9623 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 8.16.0; fixed in 17.2.9, 17.3.5, 17.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9623/ (Markdown: https://insights.sbomify.com/CVE-2024-9623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9623
- OSV: https://osv.dev/vulnerability/CVE-2024-9623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9623/
Summaries are generated and may contain mistakes; the official description above is the record.
