# CVE-2024-9631: Inefficient Algorithmic Complexity in GitLab

> Attackers can cause denial of service by triggering slow diff rendering in GitLab merge requests with conflicts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2025
- **Updated:** 5 Feb 2025
- **Also known as:** BIT-gitlab-2024-9631, GHSA-rfm6-5393-x9wf, UBUNTU-CVE-2024-9631

## What is CVE-2024-9631?

CVE-2024-9631 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 13.6 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, where viewing diffs of MR with conflicts can be slow.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2024-9631?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 13.6.0 | 17.4.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-9631?

Upgrade gitlab to 17.4.2 or later.

## Is CVE-2024-9631 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9631 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9631 and fix it if it is affected.

What it is: CVE-2024-9631 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9631 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 13.6.0; fixed in 17.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9631/ (Markdown: https://insights.sbomify.com/CVE-2024-9631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9631
- OSV: https://osv.dev/vulnerability/CVE-2024-9631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9631/
Summaries are generated and may contain mistakes; the official description above is the record.
