CVE-2024-9866 Cross-site scripting in Event Tickets with Ticket Scanner

Medium 5.4 Published Updated

Authenticated attackers can inject arbitrary scripts via ticket management features, leading to stored XSS and potential session hijacking.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-9866?

CVE-2024-9866 is a medium-severity cross-site scripting vulnerability in sasonikolov Event Tickets with Ticket Scanner, published on 6 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

The Event Tickets with Ticket Scanner plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'data' parameters in all versions up to, and including, 2.4.4 due to insufficient input sanitization and output escaping and missing authorization on the functionality to manage tickets. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This missing authorization aspect of this was patched in 2.4.1, while the Cross-Site Scripting was fully patched in 2.4.4.

Weakness: CWE-79

Which versions are affected by CVE-2024-9866?

How do I fix CVE-2024-9866?

No fix has been published for CVE-2024-9866 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-9866 being exploited?

There is no known exploitation of CVE-2024-9866 in the wild and no public exploit code.

Sources

Also known as GHSA-mw3h-whj3-q5rc.

Is CVE-2024-9866 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free