{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-9866 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-9866 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-9866 is a medium-severity cross-site scripting vulnerability in sasonikolov Event Tickets with Ticket Scanner, published on 6 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-9866 and fix it if it is affected.\n\nWhat it is: CVE-2024-9866 is a medium-severity cross-site scripting vulnerability in sasonikolov Event Tickets with Ticket Scanner, published on 6 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-9866 in the wild and no public exploit code.\n\nAffected product: sasonikolov Event Tickets with Ticket Scanner. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9866/ (Markdown: https://insights.sbomify.com/CVE-2024-9866/index.md)","id":"CVE-2024-9866","markdown":"https://insights.sbomify.com/CVE-2024-9866/index.md","name":"CVE-2024-9866","record":{"aliases":["GHSA-mw3h-whj3-q5rc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers can inject arbitrary scripts via ticket management features, leading to stored XSS and potential session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Event Tickets with Ticket Scanner plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'data' parameters in all versions up to, and including, 2.4.4 due to insufficient input sanitization and output escaping and missing authorization on the functionality to manage tickets. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This missing authorization aspect of this was patched in 2.4.1, while the Cross-Site Scripting was fully patched in 2.4.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in Event Tickets with Ticket Scanner","id":"CVE-2024-9866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"Cross-site scripting in Element Pack – Widgets, Templates \u0026 Addons for Elementor","id":"CVE-2024-9867"},"packages":[],"prev":{"headline":"Cross-site scripting in EventPrime – Events Calendar, Bookings and Tickets","id":"CVE-2024-9865"},"products":["Event Tickets with Ticket Scanner"],"published":"2024-12-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["sasonikolov"]},"summary":"Authenticated attackers can inject arbitrary scripts via ticket management features, leading to stored XSS and potential session hijacking.","url":"https://insights.sbomify.com/CVE-2024-9866/"}