# CVE-2024-9900: Cross-Site Scripting (XSS) in mudler/localai

> Attackers can inject malicious JavaScript via search input in LocalAI, potentially stealing session cookies or hijacking user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-w6hh-w36c-vxmw, GO-2025-3542

## What is CVE-2024-9900?

CVE-2024-9900 is a medium-severity cross-site scripting vulnerability in mudler/localai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

mudler/localai version v2.21.1 contains a Cross-Site Scripting (XSS) vulnerability in its search functionality. The vulnerability arises due to improper sanitization of user input, allowing the injection and execution of arbitrary JavaScript code. This can lead to the execution of malicious scripts in the context of the victim's browser, potentially compromising user sessions, stealing session cookies, redirecting users to malicious websites, or manipulating the DOM.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-9900?

3 open source packages ship an affected version, including github.com/mudler/LocalAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mudler/LocalAI` | Go | All versions | None |
| `github.com/mudler/LocalAI` | Go | All versions | 2.22.0 |
| `github.com/mudler/LocalAI` | Go | All versions | 2.22.0 |

Products: Mudler Localai.

## How do I fix CVE-2024-9900?

Upgrade github.com/mudler/LocalAI to 2.22.0 or later.

## Is CVE-2024-9900 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9900 exists.

## Other vulnerabilities in mudler/localai

- [CVE-2024-5181](https://insights.sbomify.com/CVE-2024-5181/): Command Injection in mudler/localai (critical 9.8)
- [CVE-2024-2029](https://insights.sbomify.com/CVE-2024-2029/): Command Injection in mudler/localai (critical 9.8)
- [CVE-2024-6983](https://insights.sbomify.com/CVE-2024-6983/): Remote Code Execution in mudler/localai (high 8.8)
- [CVE-2024-6868](https://insights.sbomify.com/CVE-2024-6868/): Arbitrary File Write in mudler/LocalAI (high 8.1)
- [CVE-2024-7010](https://insights.sbomify.com/CVE-2024-7010/): Timing Attack in mudler/localai (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9900 and fix it if it is affected.

What it is: CVE-2024-9900 is a medium-severity cross-site scripting vulnerability in mudler/localai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9900 exists.

Affected packages and fixed versions:
- github.com/mudler/LocalAI (Go): affected all versions; no fix listed
- github.com/mudler/LocalAI (Go): affected all versions; fixed in 2.22.0
- github.com/mudler/LocalAI (Go): affected all versions; fixed in 2.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9900/ (Markdown: https://insights.sbomify.com/CVE-2024-9900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9900
- OSV: https://osv.dev/vulnerability/CVE-2024-9900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9900/
Summaries are generated and may contain mistakes; the official description above is the record.
