{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-9946 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-9946 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-9946 is a high-severity authentication bypass vulnerability in the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-9946 and fix it if it is affected.\n\nWhat it is: CVE-2024-9946 is a high-severity authentication bypass vulnerability in the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-9946 in the wild and no public exploit code.\n\nAffected product: the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9946/ (Markdown: https://insights.sbomify.com/CVE-2024-9946/index.md)","id":"CVE-2024-9946","markdown":"https://insights.sbomify.com/CVE-2024-9946/index.md","name":"CVE-2024-9946","record":{"aliases":["GHSA-mgwf-rf72-8j49"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can log in as existing users via insufficient OAuth verification in the Super Socializer WordPress plugin.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"super_socializer","vendor":"heateor"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"The Social Share, Social Login and Social Comments Plugin – Super Socializer plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 7.13.68. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, if they have access to the email and the user does not have an already-existing account for the service returning the token. An attacker cannot authenticate as an administrator by default, but these accounts are also at risk if authentication for administrators has explicitly been allowed via the social login. The vulnerability was partially patched in version 7.13.68.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Auth bypass in Social Share, Social Login and Social Comments Plugin – Super Socializer","id":"CVE-2024-9946","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"ProfilePress - Pro \u003c= 4.11.1 - Authentication Bypass via WordPress.com OAuth provider","id":"CVE-2024-9947"},"packages":[],"prev":{"headline":"Limited Information Disclosure in GoAnywhere MFT Prior to 7.7.0","id":"CVE-2024-9945"},"products":["Social Share, Social Login and Social Comments Plugin – Super Socializer"],"published":"2024-11-06","related":[{"cvss_score":6.5,"headline":"WordPress Super Socializer Plugin \u003c= 7.13.52 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-35882","kev_date_added":null,"published":"2023-06-20"},{"cvss_score":6.1,"headline":"Super Socializer \u003c 7.13.30 - Reflected Cross-Site Scripting","id":"CVE-2021-24987","kev_date_added":null,"published":"2022-04-11"},{"cvss_score":5.4,"headline":"Super Socializer \u003c 7.13.44 - Contributor+ Stored XSS","id":"CVE-2022-4484","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":5.3,"headline":"SQL injection in Social Share, Social Login and Social Comments Plugin – Super Socializer","id":"CVE-2024-13230","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":4.8,"headline":"Super Socializer \u003c 7.13.64 - Editor+ Stored XSS","id":"CVE-2024-2836","kev_date_added":null,"published":"2024-04-15"},{"cvss_score":4.3,"headline":"WordPress Super Socializer plugin \u003c= 7.13.54 - Broken Access Control vulnerability","id":"CVE-2023-41802","kev_date_added":null,"published":"2024-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["the_champ"]},"summary":"Unauthenticated attackers can log in as existing users via insufficient OAuth verification in the Super Socializer WordPress plugin.","url":"https://insights.sbomify.com/CVE-2024-9946/"}