# CVE-2024-9946: Auth bypass in Social Share, Social Login and Social Comments Plugin – Super Socializer

> Unauthenticated attackers can log in as existing users via insufficient OAuth verification in the Super Socializer WordPress plugin.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Nov 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-mgwf-rf72-8j49

## What is CVE-2024-9946?

CVE-2024-9946 is a high-severity authentication bypass vulnerability in the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Social Share, Social Login and Social Comments Plugin – Super Socializer plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 7.13.68. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, if they have access to the email and the user does not have an already-existing account for the service returning the token. An attacker cannot authenticate as an administrator by default, but these accounts are also at risk if authentication for administrators has explicitly been allowed via the social login. The vulnerability was partially patched in version 7.13.68.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-9946?

It affects 1 product.


Products: Heateor Super Socializer.

## How do I fix CVE-2024-9946?

No fix has been published for CVE-2024-9946 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-9946 being exploited?

There is no known exploitation of CVE-2024-9946 in the wild and no public exploit code.

## Other vulnerabilities in the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer

- [CVE-2023-35882](https://insights.sbomify.com/CVE-2023-35882/): WordPress Super Socializer Plugin <= 7.13.52 is vulnerable to Cross Site Scripting (XSS) (medium 6.5)
- [CVE-2021-24987](https://insights.sbomify.com/CVE-2021-24987/): Super Socializer < 7.13.30 - Reflected Cross-Site Scripting (medium 6.1)
- [CVE-2022-4484](https://insights.sbomify.com/CVE-2022-4484/): Super Socializer < 7.13.44 - Contributor+ Stored XSS (medium 5.4)
- [CVE-2024-13230](https://insights.sbomify.com/CVE-2024-13230/): SQL injection in Social Share, Social Login and Social Comments Plugin – Super Socializer (medium 5.3)
- [CVE-2024-2836](https://insights.sbomify.com/CVE-2024-2836/): Super Socializer < 7.13.64 - Editor+ Stored XSS (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9946 and fix it if it is affected.

What it is: CVE-2024-9946 is a high-severity authentication bypass vulnerability in the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-9946 in the wild and no public exploit code.

Affected product: the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9946/ (Markdown: https://insights.sbomify.com/CVE-2024-9946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9946
- OSV: https://osv.dev/vulnerability/CVE-2024-9946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9946/
Summaries are generated and may contain mistakes; the official description above is the record.
