# CVE-2024-9979: Pyo3: risk of use-after-free in `borrowed` reads from python weak references

> Attackers can trigger use-after-free via unsound borrowing from weak Python references, potentially causing memory corruption or crashes in applications using PyO3.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2024
- **Updated:** 20 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-9979, GHSA-6jgw-rgmm-7cv6, RUSTSEC-2024-0378

## What is CVE-2024-9979?

CVE-2024-9979 is a medium-severity use after free vulnerability in Red Hat Ansible Automation Platform 2, published on 15 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in PyO3. This vulnerability causes a use-after-free issue, potentially leading to memory corruption or crashes via unsound borrowing from weak Python references.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2024-9979?

3 open source packages ship an affected version, including pyo3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyo3` | crates.io | From 0.22.0 | 0.22.4 |
| `pyo3` | crates.io | From 0.22.0 | 0.22.4 |
| `pyo3` | crates.io | From 0.22.0 | 0.22.4 |

## How do I fix CVE-2024-9979?

Upgrade pyo3 to 0.22.4 or later.

## Is CVE-2024-9979 being exploited?

There is no known exploitation of CVE-2024-9979 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9979 and fix it if it is affected.

What it is: CVE-2024-9979 is a medium-severity use after free vulnerability in Red Hat Ansible Automation Platform 2, published on 15 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-9979 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyo3 (crates.io): affected from 0.22.0; fixed in 0.22.4
- pyo3 (crates.io): affected from 0.22.0; fixed in 0.22.4
- pyo3 (crates.io): affected from 0.22.0; fixed in 0.22.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9979/ (Markdown: https://insights.sbomify.com/CVE-2024-9979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9979
- OSV: https://osv.dev/vulnerability/CVE-2024-9979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9979/
Summaries are generated and may contain mistakes; the official description above is the record.
