# CVE-2025-0142: Zoom Jenkins Marketplace plugin - Cleartext Storage of Sensitive Information

> An authenticated user can disclose sensitive information stored in cleartext within the Zoom Jenkins Marketplace plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2025
- **Updated:** 31 Jan 2025
- **Also known as:** GHSA-jx45-xp6q-cwjc

## What is CVE-2025-0142?

CVE-2025-0142 is a medium-severity vulnerability in Zoom Jenkins Marketplace plugin, published on 30 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cleartext storage of sensitive information in the Zoom Jenkins Marketplace plugin before version 1.4 may allow an authenticated user to conduct a disclosure of information via network access.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2025-0142?

2 open source packages ship an affected version, including io.jenkins.plugins:zoom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:zoom` | Maven | All versions | 1.4 |
| `io.jenkins.plugins:zoom` | Maven | All versions | 1.4 |

## How do I fix CVE-2025-0142?

Upgrade io.jenkins.plugins:zoom to 1.4 or later.

## Is CVE-2025-0142 being exploited?

There is no known exploitation of CVE-2025-0142 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0142 and fix it if it is affected.

What it is: CVE-2025-0142 is a medium-severity vulnerability in Zoom Jenkins Marketplace plugin, published on 30 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-0142 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:zoom (Maven): affected all versions; fixed in 1.4
- io.jenkins.plugins:zoom (Maven): affected all versions; fixed in 1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0142/ (Markdown: https://insights.sbomify.com/CVE-2025-0142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0142
- OSV: https://osv.dev/vulnerability/CVE-2025-0142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0142/
Summaries are generated and may contain mistakes; the official description above is the record.
