CVE-2025-0182 Denial of Service in danswer-ai/danswer
Attackers can cause denial of service via memory exhaustion by sending multiple requests to the SAML callback endpoint in Danswer.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-0182?
CVE-2025-0182 is a high-severity denial of service vulnerability in danswer-ai/danswer, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability in danswer-ai/danswer version 0.9.0 allows for denial of service through memory exhaustion. The issue arises from the use of a vulnerable version of the starlette package (<=0.49) via fastapi, which was patched in fastapi version 0.115.3. The vulnerability can be exploited by sending multiple requests to the /auth/saml/callback endpoint, leading to uncontrolled memory consumption and eventual denial of service.
Weakness: CWE-770
Which versions are affected by CVE-2025-0182?
How do I fix CVE-2025-0182?
No fix has been published for CVE-2025-0182 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-0182 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0182 exists.
Sources
Also known as GHSA-vrw3-r7jw-4785.