CVE-2025-0186 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause denial of service by exhausting server resources via crafted requests to a discussions endpoint in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-0186?

CVE-2025-0186 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.6 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that could have allowed an authenticated user to cause denial of service under certain conditions by exhausting server resources by making crafted requests to a discussions endpoint.

Weakness: CWE-770

Which versions are affected by CVE-2025-0186?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.6.018.9.6, 18.10.4, 18.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-0186?

Upgrade gitlab to a fixed version for your release line: 18.9.6, 18.10.4 or 18.11.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-0186 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0186 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-0186, GHSA-vhmr-xxmg-qhfg, UBUNTU-CVE-2025-0186.

Is CVE-2025-0186 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free