CVE-2025-0194 Insertion of Sensitive Information into Externally-Accessible File or Directory in GitLab
Attackers can read access tokens from logs if API requests are made in a specific manner, potentially leading to unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-0194?
CVE-2025-0194 is a medium-severity vulnerability in Gitlab Gitlab, published on 8 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 17.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1. Under certain conditions, access tokens may have been logged when API requests were made in a specific manner.
Weakness: CWE-538
Which versions are affected by CVE-2025-0194?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.4.0 | 17.5.5, 17.6.3, 17.7.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-0194?
Upgrade gitlab to a fixed version for your release line: 17.5.5, 17.6.3 or 17.7.1.
Is CVE-2025-0194 being exploited?
There is no known exploitation of CVE-2025-0194 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-0194, GHSA-fv26-qm6r-mmq5, UBUNTU-CVE-2025-0194.