{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0281 exists.","fix":"No fix has been published for CVE-2025-0281 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-0281 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 20 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-0281 and fix it if it is affected.\n\nWhat it is: CVE-2025-0281 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 20 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0281 exists.\n\nAffected product: Lunary Lunary. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-0281/ (Markdown: https://insights.sbomify.com/CVE-2025-0281/index.md)","id":"CVE-2025-0281","markdown":"https://insights.sbomify.com/CVE-2025-0281/index.md","name":"CVE-2025-0281","record":{"aliases":["GHSA-vqqv-6pvc-4m7q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Lunary AI platform","requires_auth":"low_privilege","summary":"Attackers can inject malicious JavaScript via SAML metadata, leading to arbitrary code execution and session hijacking in the Lunary AI web application.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"lunary","vendor":"lunary"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A stored cross-site scripting (XSS) vulnerability exists in lunary-ai/lunary versions 1.6.7 and earlier. An attacker can inject malicious JavaScript into the SAML IdP XML metadata, which is used to generate the SAML login redirect URL. This URL is then set as the value of `window.location.href` without proper validation or sanitization. This vulnerability allows the attacker to execute arbitrary JavaScript in the context of the user's browser, potentially leading to session hijacking, data theft, or other malicious actions. The issue is fixed in version 1.7.10.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Stored Cross-Site Scripting (XSS) in lunary-ai/lunary","id":"CVE-2025-0281","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"lunary:lunary","products":["lunary:lunary"],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Ivanti Connect Secure, Policy Secure, and ZTA Gateways Stack-Based Buffer Overflow","id":"CVE-2025-0282"},"packages":[],"prev":{"headline":"HCL Compass is affected by a security vulnerability","id":"CVE-2025-0280"},"products":["lunary-ai/lunary"],"published":"2025-03-20","related":[{"cvss_score":9.8,"headline":"Improper Access Control in lunary-ai/lunary","id":"CVE-2024-8999","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"Improper Authorization in lunary-ai/lunary","id":"CVE-2024-9095","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"SQL Injection in lunary-ai/lunary","id":"CVE-2024-7456","kev_date_added":null,"published":"2024-11-01"},{"cvss_score":9.8,"headline":"Incorrect Authorization in lunary-ai/lunary","id":"CVE-2024-4146","kev_date_added":null,"published":"2024-06-08"},{"cvss_score":9.6,"headline":"Account Hijacking via Password Reset Token Leak in lunary-ai/lunary","id":"CVE-2024-5386","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.6,"headline":"Incorrect Authorization in lunary-ai/lunary","id":"CVE-2024-3379","kev_date_added":null,"published":"2024-11-14"},{"cvss_score":9.4,"headline":"IDOR Vulnerability in lunary-ai/lunary","id":"CVE-2024-5128","kev_date_added":null,"published":"2024-06-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-20","vendors":["lunary-ai"]},"summary":"Attackers can inject malicious JavaScript via SAML metadata, leading to arbitrary code execution and session hijacking in the Lunary AI web application.","url":"https://insights.sbomify.com/CVE-2025-0281/"}