# CVE-2025-0281: Stored Cross-Site Scripting (XSS) in lunary-ai/lunary

> Attackers can inject malicious JavaScript via SAML metadata, leading to arbitrary code execution and session hijacking in the Lunary AI web application.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-vqqv-6pvc-4m7q

## What is CVE-2025-0281?

CVE-2025-0281 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 20 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability exists in lunary-ai/lunary versions 1.6.7 and earlier. An attacker can inject malicious JavaScript into the SAML IdP XML metadata, which is used to generate the SAML login redirect URL. This URL is then set as the value of `window.location.href` without proper validation or sanitization. This vulnerability allows the attacker to execute arbitrary JavaScript in the context of the user's browser, potentially leading to session hijacking, data theft, or other malicious actions. The issue is fixed in version 1.7.10.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-0281?

It affects 1 product.


Products: Lunary Lunary.

## How do I fix CVE-2025-0281?

No fix has been published for CVE-2025-0281 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-0281 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0281 exists.

## Other vulnerabilities in Lunary Lunary

- [CVE-2024-8999](https://insights.sbomify.com/CVE-2024-8999/): Improper Access Control in lunary-ai/lunary (critical 9.8)
- [CVE-2024-9095](https://insights.sbomify.com/CVE-2024-9095/): Improper Authorization in lunary-ai/lunary (critical 9.8)
- [CVE-2024-7456](https://insights.sbomify.com/CVE-2024-7456/): SQL Injection in lunary-ai/lunary (critical 9.8)
- [CVE-2024-4146](https://insights.sbomify.com/CVE-2024-4146/): Incorrect Authorization in lunary-ai/lunary (critical 9.8)
- [CVE-2024-5386](https://insights.sbomify.com/CVE-2024-5386/): Account Hijacking via Password Reset Token Leak in lunary-ai/lunary (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0281 and fix it if it is affected.

What it is: CVE-2025-0281 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 20 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0281 exists.

Affected product: Lunary Lunary. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0281/ (Markdown: https://insights.sbomify.com/CVE-2025-0281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0281
- OSV: https://osv.dev/vulnerability/CVE-2025-0281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0281/
Summaries are generated and may contain mistakes; the official description above is the record.
