CVE-2025-0290 Loop with Unreachable Exit Condition ('Infinite Loop') in GitLab

Medium 4.3 Published Updated

Attackers can cause background jobs to become unresponsive by processing malicious CI artifacts metadata, leading to a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-0290?

CVE-2025-0290 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 28 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.0 prior to 17.5.5, from 17.6 prior to 17.6.3, and from 17.7 prior to 17.7.1. Under certain conditions, processing of CI artifacts metadata could cause background jobs to become unresponsive.

Weakness: CWE-835

Which versions are affected by CVE-2025-0290?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.0.017.6.4, 17.7.2, 17.8.0

Products include Gitlab Gitlab.

How do I fix CVE-2025-0290?

Upgrade gitlab to a fixed version for your release line: 17.6.4, 17.7.2 or 17.8.0.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-0290 being exploited?

There is no known exploitation of CVE-2025-0290 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-0290, GHSA-j6mm-pjh3-2fh5, UBUNTU-CVE-2025-0290.

Is CVE-2025-0290 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free