CVE-2025-0314 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

Attackers can execute arbitrary scripts in victim browsers via improper file rendering, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-0314?

CVE-2025-0314 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 24 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.2 before 17.6.4, 17.7 before 17.7.3, and 17.8 before 17.8.1. Improper rendering of certain file types lead to cross-site scripting.

Weakness: CWE-79

Which versions are affected by CVE-2025-0314?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.2.017.6.4, 17.7.3, 17.8.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-0314?

Upgrade gitlab to a fixed version for your release line: 17.6.4, 17.7.3 or 17.8.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-0314 being exploited?

There is no known exploitation of CVE-2025-0314 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-0314, GHSA-rww2-m274-8f9v, UBUNTU-CVE-2025-0314.

Is CVE-2025-0314 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free