{"answers":{"affected":"3 open source packages ship an affected version, including sagemaker.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0508 exists.","fix":"Upgrade sagemaker to 2.237.3 or later.","what":"CVE-2025-0508 is a medium-severity vulnerability in aws/sagemaker-python-sdk, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-0508 and fix it if it is affected.\n\nWhat it is: CVE-2025-0508 is a medium-severity vulnerability in aws/sagemaker-python-sdk, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0508 exists.\n\nAffected packages and fixed versions:\n- sagemaker (PyPI): affected all versions; fixed in 2.237.3\n- sagemaker (PyPI): affected all versions; fixed in 2.237.3\n- sagemaker (PyPI): affected all versions; fixed in 2.237.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-0508/ (Markdown: https://insights.sbomify.com/CVE-2025-0508/index.md)","id":"CVE-2025-0508","markdown":"https://insights.sbomify.com/CVE-2025-0508/index.md","name":"CVE-2025-0508","record":{"aliases":["GHSA-32g6-mg92-ghm2","PYSEC-2026-1885"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","other"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS SageMaker SDK","requires_auth":"none","summary":"MD5 hash collisions in SageMaker workflows allow attackers to replace workflow results, causing integrity issues and erroneous processing outcomes.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-328","name":"Use of Weak Hash"}],"description":"A vulnerability in the SageMaker Workflow component of aws/sagemaker-python-sdk allows for the possibility of MD5 hash collisions in all versions. This can lead to workflows being inadvertently replaced due to the reuse of results from different configurations that produce the same MD5 hash. This issue can cause integrity problems within the pipeline, potentially leading to erroneous processing outcomes.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"MD5 Hash Collision in SageMaker Workflow in aws/sagemaker-python-sdk","id":"CVE-2025-0508","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Signing Checks Bypass","id":"CVE-2025-0509"},"packages":[{"ecosystem":"PyPI","fixed":["2.237.3"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":null,"source":"GHSA-32g6-mg92-ghm2"},{"ecosystem":"PyPI","fixed":["2.237.3"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":"pkg:pypi/sagemaker","source":"GHSA-32g6-mg92-ghm2"},{"ecosystem":"PyPI","fixed":["2.237.3"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":"pkg:pypi/sagemaker","source":"PYSEC-2026-1885"}],"prev":{"headline":"Cross-site scripting in Ticketmeo – Sell Tickets – Event Ticketing","id":"CVE-2025-0507"},"products":["aws/sagemaker-python-sdk"],"published":"2025-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["aws"]},"summary":"MD5 hash collisions in SageMaker workflows allow attackers to replace workflow results, causing integrity issues and erroneous processing outcomes.","url":"https://insights.sbomify.com/CVE-2025-0508/"}