# CVE-2025-0508: MD5 Hash Collision in SageMaker Workflow in aws/sagemaker-python-sdk

> MD5 hash collisions in SageMaker workflows allow attackers to replace workflow results, causing integrity issues and erroneous processing outcomes.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-32g6-mg92-ghm2, PYSEC-2026-1885

## What is CVE-2025-0508?

CVE-2025-0508 is a medium-severity vulnerability in aws/sagemaker-python-sdk, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the SageMaker Workflow component of aws/sagemaker-python-sdk allows for the possibility of MD5 hash collisions in all versions. This can lead to workflows being inadvertently replaced due to the reuse of results from different configurations that produce the same MD5 hash. This issue can cause integrity problems within the pipeline, potentially leading to erroneous processing outcomes.

Weakness: CWE-328 (Use of Weak Hash)

## Which versions are affected by CVE-2025-0508?

3 open source packages ship an affected version, including sagemaker.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sagemaker` | PyPI | All versions | 2.237.3 |
| `sagemaker` | PyPI | All versions | 2.237.3 |
| `sagemaker` | PyPI | All versions | 2.237.3 |

## How do I fix CVE-2025-0508?

Upgrade sagemaker to 2.237.3 or later.

## Is CVE-2025-0508 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0508 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0508 and fix it if it is affected.

What it is: CVE-2025-0508 is a medium-severity vulnerability in aws/sagemaker-python-sdk, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0508 exists.

Affected packages and fixed versions:
- sagemaker (PyPI): affected all versions; fixed in 2.237.3
- sagemaker (PyPI): affected all versions; fixed in 2.237.3
- sagemaker (PyPI): affected all versions; fixed in 2.237.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0508/ (Markdown: https://insights.sbomify.com/CVE-2025-0508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0508
- OSV: https://osv.dev/vulnerability/CVE-2025-0508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0508/
Summaries are generated and may contain mistakes; the official description above is the record.
