CVE-2025-0509 Signing Checks Bypass
Attackers can bypass Sparkle's signing checks to replace signed updates with malicious payloads, leading to arbitrary code execution on macOS applications.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-0509?
CVE-2025-0509 is a high-severity vulnerability in Netapp Hci Compute Node, published on 4 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.
Weakness: CWE-552
Which versions are affected by CVE-2025-0509?
5 open source packages ship an affected version, including github.com/sparkle-project/Sparkle, java and java-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/sparkle-project/Sparkle SwiftURL | All versions | 2.6.4 |
github.com/sparkle-project/Sparkle SwiftURL | All versions | 2.6.4 |
java Bitnami | All versions | 1.8.0, 8.0.441 |
java-min Bitnami | All versions | 1.8.0, 8.0.441 |
jre Bitnami | All versions | 1.8.0, 8.0.441 |
Products include Netapp Hci Compute Node, Netapp Oncommand Workflow Automation, Sparkle-Project Sparkle.
How do I fix CVE-2025-0509?
Upgrade github.com/sparkle-project/Sparkle to 2.6.4 or later.
Is CVE-2025-0509 being exploited?
There is no known exploitation of CVE-2025-0509 in the wild and no public exploit code.
Other vulnerabilities in Netapp Hci Compute Node
Sources
Also known as BIT-java-2025-0509, BIT-java-min-2025-0509, BIT-jre-2025-0509, GHSA-wc9m-r3v6-9p5h, MINI-pwmv-424q-xfw4, UBUNTU-CVE-2025-0509.