# CVE-2025-0509: Signing Checks Bypass

> Attackers can bypass Sparkle's signing checks to replace signed updates with malicious payloads, leading to arbitrary code execution on macOS applications.

- **Severity:** High 7.3 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2025
- **Updated:** 17 Feb 2025
- **Also known as:** BIT-java-2025-0509, BIT-java-min-2025-0509, BIT-jre-2025-0509, GHSA-wc9m-r3v6-9p5h, MINI-pwmv-424q-xfw4, UBUNTU-CVE-2025-0509

## What is CVE-2025-0509?

CVE-2025-0509 is a high-severity vulnerability in Netapp Hci Compute Node, published on 4 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2025-0509?

5 open source packages ship an affected version, including github.com/sparkle-project/Sparkle, java and java-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sparkle-project/Sparkle` | SwiftURL | All versions | 2.6.4 |
| `github.com/sparkle-project/Sparkle` | SwiftURL | All versions | 2.6.4 |
| `java` | Bitnami | All versions | 1.8.0, 8.0.441 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.441 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.441 |

Products: Netapp Hci Compute Node, Netapp Oncommand Workflow Automation, Sparkle-Project Sparkle.

## How do I fix CVE-2025-0509?

Upgrade github.com/sparkle-project/Sparkle to 2.6.4 or later.

## Is CVE-2025-0509 being exploited?

There is no known exploitation of CVE-2025-0509 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Hci Compute Node

- [CVE-2025-27423](https://insights.sbomify.com/CVE-2025-27423/): Improper Input Validation in Vim (high 7.1)
- [CVE-2024-3447](https://insights.sbomify.com/CVE-2024-3447/): Qemu: sdhci: heap buffer overflow in sdhci_write_dataport() (medium 6.0)
- [CVE-2025-26603](https://insights.sbomify.com/CVE-2025-26603/): heap-use-after-free in function str_to_reg in vim/vim (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0509 and fix it if it is affected.

What it is: CVE-2025-0509 is a high-severity vulnerability in Netapp Hci Compute Node, published on 4 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-0509 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sparkle-project/Sparkle (SwiftURL): affected all versions; fixed in 2.6.4
- github.com/sparkle-project/Sparkle (SwiftURL): affected all versions; fixed in 2.6.4
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.441
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.441
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.441

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0509/ (Markdown: https://insights.sbomify.com/CVE-2025-0509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0509
- OSV: https://osv.dev/vulnerability/CVE-2025-0509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0509/
Summaries are generated and may contain mistakes; the official description above is the record.
