# CVE-2025-0555: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

> An attacker can execute arbitrary scripts in a user's browser via XSS in GitLab, bypassing security controls.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2025
- **Updated:** 4 Mar 2025
- **Also known as:** BIT-gitlab-2025-0555, GHSA-2862-gpw6-r482

## What is CVE-2025-0555?

CVE-2025-0555 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 3 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A Cross Site Scripting (XSS) vulnerability in GitLab-EE affecting all versions from 16.6 prior to 17.7.6, 17.8 prior to 17.8.4, and 17.9 prior to 17.9.1 allows an attacker to bypass security controls and execute arbitrary scripts in a users browser under specific conditions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-0555?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.6.0 | 17.9.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-0555?

Upgrade gitlab to 17.9.1 or later.

## Is CVE-2025-0555 being exploited?

There is no known exploitation of CVE-2025-0555 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0555 and fix it if it is affected.

What it is: CVE-2025-0555 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 3 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-0555 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.6.0; fixed in 17.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0555/ (Markdown: https://insights.sbomify.com/CVE-2025-0555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0555
- OSV: https://osv.dev/vulnerability/CVE-2025-0555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0555/
Summaries are generated and may contain mistakes; the official description above is the record.
