CVE-2025-0605 Weak Authentication in GitLab

Medium 4.6 Published Updated

Attackers can bypass two-factor authentication requirements in GitLab due to flawed group access controls, potentially gaining unauthorized access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-0605?

CVE-2025-0605 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 22 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.8 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Group access controls could allow certain users to bypass two-factor authentication requirements.

Weakness: CWE-287, CWE-1390

Which versions are affected by CVE-2025-0605?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.8.017.11.3, 18.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-0605?

Upgrade gitlab to a fixed version for your release line: 17.11.3 or 18.0.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-0605 being exploited?

There is no known exploitation of CVE-2025-0605 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-0605, GHSA-v9g5-36x8-7xmx, UBUNTU-CVE-2025-0605.

Is CVE-2025-0605 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free