{"answers":{"affected":"3 open source packages ship an affected version, including litellm.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0628 exists.","fix":"Upgrade litellm to 1.61.15 or later.","what":"CVE-2025-0628 is a high-severity vulnerability in berriai/litellm, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-0628 and fix it if it is affected.\n\nWhat it is: CVE-2025-0628 is a high-severity vulnerability in berriai/litellm, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0628 exists.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.61.15\n- litellm (PyPI): affected all versions; fixed in 1.61.15\n- litellm (PyPI): affected all versions; fixed in 1.61.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-0628/ (Markdown: https://insights.sbomify.com/CVE-2025-0628/index.md)","id":"CVE-2025-0628","markdown":"https://insights.sbomify.com/CVE-2025-0628/index.md","name":"CVE-2025-0628","record":{"aliases":["GHSA-fjcf-3j3r-78rp","PYSEC-2026-1546"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM Python library","requires_auth":"low_privilege","summary":"Attackers with viewer roles can obtain admin API keys, allowing full administrative access and privilege escalation in LiteLLM.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"An improper authorization vulnerability exists in the main-latest version of BerriAI/litellm. When a user with the role 'internal_user_viewer' logs into the application, they are provided with an overly privileged API key. This key can be used to access all the admin functionality of the application, including endpoints such as '/users/list' and '/users/get_users'. This vulnerability allows for privilege escalation within the application, enabling any account to become a PROXY ADMIN.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Authorization in BerriAI/litellm","id":"CVE-2025-0628","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Coronavirus (COVID-19) Notice Message \u003c= 1.1.2 - Admin+ Stored XSS","id":"CVE-2025-0629"},"packages":[{"ecosystem":"PyPI","fixed":["1.61.15"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-fjcf-3j3r-78rp"},{"ecosystem":"PyPI","fixed":["1.61.15"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-fjcf-3j3r-78rp"},{"ecosystem":"PyPI","fixed":["1.61.15"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-1546"}],"prev":{"headline":"AI Autotagger \u003c 3.30.0 - Admin+ Stored XSS","id":"CVE-2025-0627"},"products":["berriai/litellm"],"published":"2025-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["berriai"]},"summary":"Attackers with viewer roles can obtain admin API keys, allowing full administrative access and privilege escalation in LiteLLM.","url":"https://insights.sbomify.com/CVE-2025-0628/"}