# CVE-2025-0628: Improper Authorization in BerriAI/litellm

> Attackers with viewer roles can obtain admin API keys, allowing full administrative access and privilege escalation in LiteLLM.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-fjcf-3j3r-78rp, PYSEC-2026-1546

## What is CVE-2025-0628?

CVE-2025-0628 is a high-severity vulnerability in berriai/litellm, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper authorization vulnerability exists in the main-latest version of BerriAI/litellm. When a user with the role 'internal_user_viewer' logs into the application, they are provided with an overly privileged API key. This key can be used to access all the admin functionality of the application, including endpoints such as '/users/list' and '/users/get_users'. This vulnerability allows for privilege escalation within the application, enabling any account to become a PROXY ADMIN.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-0628?

3 open source packages ship an affected version, including litellm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.61.15 |
| `litellm` | PyPI | All versions | 1.61.15 |
| `litellm` | PyPI | All versions | 1.61.15 |

## How do I fix CVE-2025-0628?

Upgrade litellm to 1.61.15 or later.

## Is CVE-2025-0628 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0628 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0628 and fix it if it is affected.

What it is: CVE-2025-0628 is a high-severity vulnerability in berriai/litellm, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0628 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.61.15
- litellm (PyPI): affected all versions; fixed in 1.61.15
- litellm (PyPI): affected all versions; fixed in 1.61.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0628/ (Markdown: https://insights.sbomify.com/CVE-2025-0628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0628
- OSV: https://osv.dev/vulnerability/CVE-2025-0628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0628/
Summaries are generated and may contain mistakes; the official description above is the record.
