CVE-2025-0755 MongoDB C Driver bson library may be susceptible to buffer overflow
A buffer overflow in the MongoDB C driver's BSON library can cause application crashes via oversized documents, requiring an upgrade to libbson or MongoDB Server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-0755?
CVE-2025-0755 is a high-severity memory corruption vulnerability in Mongodb Mongodb, published on 18 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The various bson_append functions in the MongoDB C driver library may be susceptible to buffer overflow when performing operations that could result in a final BSON document which exceeds the maximum allowable size (INT32_MAX), resulting in a segmentation fault and possible application crash. This issue affected libbson versions prior to 1.27.5, MongoDB Server v8.0 versions prior to 8.0.1 and MongoDB Server v7.0 versions prior to 7.0.16
Weakness: CWE-122
Which versions are affected by CVE-2025-0755?
1 open source package ship an affected version, including mongodb. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mongodb Bitnami | From 7.0.0 | 7.0.16, 8.0.1 |
Products include Mongodb Libbson, Mongodb Mongodb.
How do I fix CVE-2025-0755?
Upgrade mongodb to a fixed version for your release line: 7.0.16 or 8.0.1.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2025-0755 being exploited?
There is no known exploitation of CVE-2025-0755 in the wild and no public exploit code.
Other vulnerabilities in Mongodb Mongodb
Sources
Also known as BIT-mongodb-2025-0755, DEBIAN-CVE-2025-0755, GHSA-x43h-8pfv-xx24, UBUNTU-CVE-2025-0755.