{"answers":{"affected":"1 open source package ship an affected version, including mongodb. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-0755 in the wild and no public exploit code.","fix":"Upgrade mongodb to a fixed version for your release line: 7.0.16 or 8.0.1.","what":"CVE-2025-0755 is a high-severity memory corruption vulnerability in Mongodb Mongodb, published on 18 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-0755 and fix it if it is affected.\n\nWhat it is: CVE-2025-0755 is a high-severity memory corruption vulnerability in Mongodb Mongodb, published on 18 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-0755 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mongodb (Bitnami): affected from 7.0.0; fixed in 7.0.16, 8.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-0755/ (Markdown: https://insights.sbomify.com/CVE-2025-0755/index.md)","id":"CVE-2025-0755","markdown":"https://insights.sbomify.com/CVE-2025-0755/index.md","name":"CVE-2025-0755","record":{"aliases":["BIT-mongodb-2025-0755","DEBIAN-CVE-2025-0755","GHSA-x43h-8pfv-xx24","UBUNTU-CVE-2025-0755"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"MongoDB C driver","requires_auth":"none","summary":"A buffer overflow in the MongoDB C driver's BSON library can cause application crashes via oversized documents, requiring an upgrade to libbson or MongoDB Server.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mongodb","cpe":[{"product":"libbson","vendor":"mongodb"},{"product":"mongodb","vendor":"mongodb"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"The various bson_append functions in the MongoDB C driver library may be susceptible to buffer overflow when performing operations that could result in a final BSON document which exceeds the maximum allowable size (INT32_MAX), resulting in a segmentation fault and possible application crash. This issue affected libbson versions prior to 1.27.5, MongoDB Server v8.0 versions prior to 8.0.1 and MongoDB Server v7.0 versions prior to 7.0.16","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MongoDB C Driver bson library may be susceptible to buffer overflow","id":"CVE-2025-0755","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mongodb:mongodb","products":["mongodb:mongodb"],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Hitachi Vantara Pentaho Data Integration \u0026 Analytics - Improper Control of Resource Identifiers ('Resource Injection')","id":"CVE-2025-0756"},"packages":[{"ecosystem":"Bitnami","fixed":["7.0.16","8.0.1"],"introduced":["7.0.0","8.0.0"],"last_affected":[],"package":"mongodb","purl":"pkg:bitnami/mongodb","source":"BIT-mongodb-2025-0755"}],"prev":{"headline":"Envoyproxy: openshift service mesh 2.6.3 and 2.5.6 envoy header handling allows log injection and potential spoofing","id":"CVE-2025-0754"},"products":["MongoDB Server","libbson"],"published":"2025-03-18","related":[{"cvss_score":8.1,"headline":"Memory corruption in n/a","id":"CVE-2018-16790","kev_date_added":null,"published":"2018-09-10"},{"cvss_score":4,"headline":"MongoDB C Driver bson_strfreev may be susceptible to integer overflow","id":"CVE-2024-6381","kev_date_added":null,"published":"2024-07-02"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["MongoDB Inc"]},"summary":"A buffer overflow in the MongoDB C driver's BSON library can cause application crashes via oversized documents, requiring an upgrade to libbson or MongoDB Server.","url":"https://insights.sbomify.com/CVE-2025-0755/"}