# CVE-2025-0755: MongoDB C Driver bson library may be susceptible to buffer overflow

> A buffer overflow in the MongoDB C driver's BSON library can cause application crashes via oversized documents, requiring an upgrade to libbson or MongoDB Server.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-mongodb-2025-0755, DEBIAN-CVE-2025-0755, GHSA-x43h-8pfv-xx24, UBUNTU-CVE-2025-0755

## What is CVE-2025-0755?

CVE-2025-0755 is a high-severity memory corruption vulnerability in Mongodb Mongodb, published on 18 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The various bson_append functions in the MongoDB C driver library may be susceptible to buffer overflow when performing operations that could result in a final BSON document which exceeds the maximum allowable size (INT32_MAX), resulting in a segmentation fault and possible application crash. This issue affected libbson versions prior to 1.27.5, MongoDB Server v8.0 versions prior to 8.0.1 and MongoDB Server v7.0 versions prior to 7.0.16

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-0755?

1 open source package ship an affected version, including mongodb. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 7.0.0 | 7.0.16, 8.0.1 |

Products: Mongodb Libbson, Mongodb Mongodb.

## How do I fix CVE-2025-0755?

Upgrade mongodb to a fixed version for your release line: 7.0.16 or 8.0.1.

## Is CVE-2025-0755 being exploited?

There is no known exploitation of CVE-2025-0755 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2018-16790](https://insights.sbomify.com/CVE-2018-16790/): Memory corruption in n/a (high 8.1)
- [CVE-2024-6381](https://insights.sbomify.com/CVE-2024-6381/): MongoDB C Driver bson_strfreev may be susceptible to integer overflow (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0755 and fix it if it is affected.

What it is: CVE-2025-0755 is a high-severity memory corruption vulnerability in Mongodb Mongodb, published on 18 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-0755 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 7.0.0; fixed in 7.0.16, 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0755/ (Markdown: https://insights.sbomify.com/CVE-2025-0755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0755
- OSV: https://osv.dev/vulnerability/CVE-2025-0755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0755/
Summaries are generated and may contain mistakes; the official description above is the record.
