CVE-2025-0840 GNU Binutils objdump.c disassemble_bytes stack-based overflow
A stack-based buffer overflow in GNU Binutils objdump allows remote attackers to execute arbitrary code or cause denial of service via crafted files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-0840?
CVE-2025-0840 is a medium-severity memory corruption vulnerability in Gnu Binutils, published on 29 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability, which was classified as problematic, was found in GNU Binutils up to 2.43. This affects the function disassemble_bytes of the file binutils/objdump.c. The manipulation of the argument buf leads to stack-based buffer overflow. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.44 is able to address this issue. The identifier of the patch is baac6c221e9d69335bf41366a1c7d87d8ab2f893. It is recommended to upgrade the affected component.
Which versions are affected by CVE-2025-0840?
It affects 1 product.
Linux distribution packages (1)
binutils openSUSE:Tumbleweed | All versions | 2.45-2.1 |
Products include Gnu Binutils.
How do I fix CVE-2025-0840?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2025-0840 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0840 exists.
Other vulnerabilities in Gnu Binutils
Sources
Also known as ALPINE-CVE-2025-0840, AZL-56099, AZL-56103, BELL-CVE-2025-0840, CLSA-2025-1741628714, CLSA-2025-1741779141 and 19 more.