{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0840 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-0840 is a medium-severity memory corruption vulnerability in Gnu Binutils, published on 29 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-0840 and fix it if it is affected.\n\nWhat it is: CVE-2025-0840 is a medium-severity memory corruption vulnerability in Gnu Binutils, published on 29 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0840 exists.\n\nAffected product: Gnu Binutils. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-0840/ (Markdown: https://insights.sbomify.com/CVE-2025-0840/index.md)","id":"CVE-2025-0840","markdown":"https://insights.sbomify.com/CVE-2025-0840/index.md","name":"CVE-2025-0840","record":{"aliases":["ALPINE-CVE-2025-0840","AZL-56099","AZL-56103","BELL-CVE-2025-0840","CLSA-2025-1741628714","CLSA-2025-1741779141","CLSA-2025-1741779457","CLSA-2025-1741779966","CLSA-2025-1741787747","CLSA-2025-1741964468","CLSA-2025-1742232795","CLSA-2025-1742317463","CLSA-2025-1742379365","CLSA-2025-1742391294","CLSA-2025-1747926654","CLSA-2025-1761323691","CLSA-2025-1764688910","DEBIAN-CVE-2025-0840","ECHO-f079-5d5a-ac2d","GHSA-c5qp-mx9f-m5c7","MINI-r6x4-pprp-2x44","OESA-2025-1129","ROOT-OS-DEBIAN-12-CVE-2025-0840","UBUNTU-CVE-2025-0840","openSUSE-SU-2025:15725-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GNU Binutils objdump","requires_auth":"none","summary":"A stack-based buffer overflow in GNU Binutils objdump allows remote attackers to execute arbitrary code or cause denial of service via crafted files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"binutils","vendor":"gnu"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"},{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability, which was classified as problematic, was found in GNU Binutils up to 2.43. This affects the function disassemble_bytes of the file binutils/objdump.c. The manipulation of the argument buf leads to stack-based buffer overflow. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.44 is able to address this issue. The identifier of the patch is baac6c221e9d69335bf41366a1c7d87d8ab2f893. It is recommended to upgrade the affected component.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"GNU Binutils objdump.c disassemble_bytes stack-based overflow","id":"CVE-2025-0840","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"gnu:binutils","products":["gnu:binutils"],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":7,"next":{"headline":"Aridius XYZ News loadMore deserialization","id":"CVE-2025-0841"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.45-2.1"],"introduced":["0"],"last_affected":[],"package":"binutils","purl":"pkg:rpm/opensuse/binutils\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15725-1"}],"prev":{"headline":"ZoomSounds \u003c= 6.91 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","id":"CVE-2025-0839"},"products":["Binutils"],"published":"2025-01-29","related":[{"cvss_score":9.8,"headline":"Null dereference in n/a","id":"CVE-2017-7614","kev_date_added":null,"published":"2017-04-09"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2014-9939","kev_date_added":null,"published":"2017-03-21"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2017-7226","kev_date_added":null,"published":"2017-03-22"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2017-6969","kev_date_added":null,"published":"2017-03-17"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2020-19726","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":7.8,"headline":"Binutils: binutils: arbitrary code execution via malformed xcoff object file processing","id":"CVE-2026-6846","kev_date_added":null,"published":"2026-04-22"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2022-44840","kev_date_added":null,"published":"2023-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["GNU"]},"summary":"A stack-based buffer overflow in GNU Binutils objdump allows remote attackers to execute arbitrary code or cause denial of service via crafted files.","url":"https://insights.sbomify.com/CVE-2025-0840/"}