{"answers":{"affected":"2 open source packages ship an affected version, including docsgpt.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0868 exists.","fix":"No fix has been published for CVE-2025-0868 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-0868 is a critical code injection vulnerability in Arc53 DocsGPT, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-0868 and fix it if it is affected.\n\nWhat it is: CVE-2025-0868 is a critical code injection vulnerability in Arc53 DocsGPT, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-0868 exists.\n\nAffected packages and fixed versions:\n- docsgpt (npm): affected from 0.8.1 up to 0.12.0; no fix listed\n- docsgpt (npm): affected from 0.8.1 up to 0.12.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-0868/ (Markdown: https://insights.sbomify.com/CVE-2025-0868/index.md)","id":"CVE-2025-0868","markdown":"https://insights.sbomify.com/CVE-2025-0868/index.md","name":"CVE-2025-0868","record":{"aliases":["GHSA-9gff-5v8w-x922"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"DocsGPT","requires_auth":"none","summary":"An unauthorized attacker can execute arbitrary Python code via the /api/remote endpoint due to improper JSON parsing using eval().","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CERT-PL","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"A vulnerability, that could result in Remote Code Execution (RCE), has been found in DocsGPT. Due to improper parsing of JSON data using eval() an unauthorized attacker could send arbitrary Python code to be executed via /api/remote endpoint..\n\nThis issue affects DocsGPT: from 0.8.1 through 0.12.0.","ecosystems":["npm"],"exploits":{"exploitdb":1,"first_seen":"2025-04-09","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-05-25T13:14:41Z","kind":"github_poc","ref":"https://github.com/aidana-gift/CVE-2025-0868","stars":1,"title":null},{"date":"2025-04-09","kind":"exploitdb","ref":"52145","stars":null,"title":"DocsGPT 0.12.0 - Remote Code Execution"},{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-0868.yaml","stars":null,"title":"DocsGPT - Unauthenticated Remote Code Execution"}],"tier":"weaponised"},"has_fix":false,"headline":"Remote Code Execution in DocsGPT","id":"CVE-2025-0868","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Cianet ONU GW24AC Login cross site scripting","id":"CVE-2025-0869"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0.8.1"],"last_affected":["0.12.0"],"package":"docsgpt","purl":null,"source":"GHSA-9gff-5v8w-x922"},{"ecosystem":"npm","fixed":[],"introduced":["0.8.1"],"last_affected":["0.12.0"],"package":"docsgpt","purl":"pkg:npm/docsgpt","source":"GHSA-9gff-5v8w-x922"}],"prev":{"headline":"Privilege Escalation in MEAC300","id":"CVE-2025-0867"},"products":["DocsGPT"],"published":"2025-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-03","vendors":["Arc53"]},"summary":"An unauthorized attacker can execute arbitrary Python code via the /api/remote endpoint due to improper JSON parsing using eval().","url":"https://insights.sbomify.com/CVE-2025-0868/"}