# CVE-2025-0914: Velociraptor Shell Plugin Prevent_execve Bypass

> Authenticated users can bypass the prevent_execve security restriction to execute arbitrary commands in Velociraptor deployments where this non-default setting is enabled.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2025
- **Updated:** 27 Feb 2025
- **Also known as:** GHSA-3q7x-q7fm-whrm

## What is CVE-2025-0914?

CVE-2025-0914 is a low-severity vulnerability in Rapid7 Velociraptor, published on 27 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2025-0914?


## How do I fix CVE-2025-0914?

Upgrade to a fixed version.

## Is CVE-2025-0914 being exploited?

There is no known exploitation of CVE-2025-0914 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0914 and fix it if it is affected.

What it is: CVE-2025-0914 is a low-severity vulnerability in Rapid7 Velociraptor, published on 27 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-0914 in the wild and no public exploit code.

Affected product: Rapid7 Velociraptor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0914/ (Markdown: https://insights.sbomify.com/CVE-2025-0914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0914
- OSV: https://osv.dev/vulnerability/CVE-2025-0914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0914/
Summaries are generated and may contain mistakes; the official description above is the record.
