CVE-2025-0916 YaySMTP 2.4.9 - 2.6.2 - Unauthenticated Stored Cross-Site Scripting
Unauthenticated attackers can inject arbitrary scripts into YaySMTP plugin pages, leading to potential session hijacking or malicious actions when users view the pages.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-0916?
CVE-2025-0916 is a high-severity cross-site scripting vulnerability in yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service, published on 19 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions 2.4.9 to 2.6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: The vulnerability has been initially patched in version 2.4.8 and was reintroduced in version 2.4.9 with the removal of the wp_kses_post() built-in WordPress sanitization function.
Weakness: CWE-79
Which versions are affected by CVE-2025-0916?
It affects 1 product.
Products include Yaycommerce Yaysmtp.
How do I fix CVE-2025-0916?
No fix has been published for CVE-2025-0916 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-0916 being exploited?
There is no known exploitation of CVE-2025-0916 in the wild and no public exploit code.
Other vulnerabilities in yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service
- CVE-2025-0918 SMTP for SendGrid – YaySMTP <= 1.4 - Unauthenticated Stored Cross-Site Scripting via Email Logs
- CVE-2025-0953 SMTP for Sendinblue – YaySMTP <= 1.2 - Unauthenticated Stored Cross-Site Scripting via Email Logs
- CVE-2023-3093 YaySMTP <= 2.4.5 - Unauthenticated Stored Cross-Site Scripting via Email
- CVE-2022-2370 YaySMTP < 2.2.1 - Subscriber+ SMTP Credentials Leak
- CVE-2022-2371 YaySMTP < 2.2.1 - Subscriber+ Stored Cross-Site Scripting
Sources
Also known as GHSA-fv43-fjwv-823r.