# CVE-2025-0916: YaySMTP 2.4.9 - 2.6.2 - Unauthenticated Stored Cross-Site Scripting

> Unauthenticated attackers can inject arbitrary scripts into YaySMTP plugin pages, leading to potential session hijacking or malicious actions when users view the pages.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Feb 2025
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-fv43-fjwv-823r

## What is CVE-2025-0916?

CVE-2025-0916 is a high-severity cross-site scripting vulnerability in yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service, published on 19 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions 2.4.9 to 2.6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: The vulnerability has been initially patched in version 2.4.8 and was reintroduced in version 2.4.9 with the removal of the wp_kses_post() built-in WordPress sanitization function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-0916?

It affects 1 product.


Products: Yaycommerce Yaysmtp.

## How do I fix CVE-2025-0916?

No fix has been published for CVE-2025-0916 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-0916 being exploited?

There is no known exploitation of CVE-2025-0916 in the wild and no public exploit code.

## Other vulnerabilities in yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service

- [CVE-2025-0918](https://insights.sbomify.com/CVE-2025-0918/): SMTP for SendGrid – YaySMTP <= 1.4 - Unauthenticated Stored Cross-Site Scripting via Email Logs (high 7.2)
- [CVE-2025-0953](https://insights.sbomify.com/CVE-2025-0953/): SMTP for Sendinblue – YaySMTP <= 1.2 - Unauthenticated Stored Cross-Site Scripting via Email Logs (high 7.2)
- [CVE-2023-3093](https://insights.sbomify.com/CVE-2023-3093/): YaySMTP <= 2.4.5 - Unauthenticated Stored Cross-Site Scripting via Email (high 7.2)
- [CVE-2022-2370](https://insights.sbomify.com/CVE-2022-2370/): YaySMTP < 2.2.1 - Subscriber+ SMTP Credentials Leak (medium 6.5)
- [CVE-2022-2371](https://insights.sbomify.com/CVE-2022-2371/): YaySMTP < 2.2.1 - Subscriber+ Stored Cross-Site Scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-0916 and fix it if it is affected.

What it is: CVE-2025-0916 is a high-severity cross-site scripting vulnerability in yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service, published on 19 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-0916 in the wild and no public exploit code.

Affected product: yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-0916/ (Markdown: https://insights.sbomify.com/CVE-2025-0916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-0916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-0916
- OSV: https://osv.dev/vulnerability/CVE-2025-0916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-0916/
Summaries are generated and may contain mistakes; the official description above is the record.
