CVE-2025-0993 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

An authenticated attacker can cause a denial of service by exhausting server resources in GitLab.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-0993?

CVE-2025-0993 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 22 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. This could allow an authenticated attacker to cause a denial of service condition by exhausting server resources.

Weakness: CWE-770

Which versions are affected by CVE-2025-0993?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions17.11.3, 18.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-0993?

Upgrade gitlab to a fixed version for your release line: 17.11.3 or 18.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-0993 being exploited?

There is no known exploitation of CVE-2025-0993 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-0993, GHSA-g93f-rhw4-8mj3, UBUNTU-CVE-2025-0993.

Is CVE-2025-0993 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free