CVE-2025-10060 MongoDB may be susceptible to Invariant Failure in Transactions due Upsert Operation

Medium 6.5 Published Updated

An attacker can crash the MongoDB server by triggering an invariant failure during upsert operations within transactions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-10060?

CVE-2025-10060 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 5 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

MongoDB Server may allow upsert operations retried within a transaction to violate unique index constraints, potentially causing an invariant failure and server crash during commit. This issue may be triggered by improper WriteUnitOfWork state management. This issue affects MongoDB Server v6.0 versions prior to 6.0.25, MongoDB Server v7.0 versions prior to 7.0.22 and MongoDB Server v8.0 versions prior to 8.0.12

Weakness: CWE-672

Which versions are affected by CVE-2025-10060?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 6.0.06.0.25, 7.0.22, 8.0.12

Products include Mongodb Mongodb.

How do I fix CVE-2025-10060?

Upgrade mongodb to a fixed version for your release line: 6.0.25, 7.0.22 or 8.0.12.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-10060 being exploited?

There is no known exploitation of CVE-2025-10060 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-10060, GHSA-95w4-863f-9mj3, MINI-2pjh-2xh6-j7mm, MINI-x6h9-rw4r-3pxx.

Is CVE-2025-10060 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free