{"answers":{"affected":"3 open source packages ship an affected version, including sglang.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10164 exists.","fix":"Upgrade sglang to 0.5.4 or later.","what":"CVE-2025-10164 is a medium-severity unsafe deserialization vulnerability in lmsys sglang, published on 9 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-10164 and fix it if it is affected.\n\nWhat it is: CVE-2025-10164 is a medium-severity unsafe deserialization vulnerability in lmsys sglang, published on 9 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10164 exists.\n\nAffected packages and fixed versions:\n- sglang (PyPI): affected all versions; fixed in 0.5.4\n- sglang (PyPI): affected all versions; fixed in 0.5.4\n- sglang (PyPI): affected all versions; fixed in 0.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10164/ (Markdown: https://insights.sbomify.com/CVE-2025-10164/index.md)","id":"CVE-2025-10164","markdown":"https://insights.sbomify.com/CVE-2025-10164/index.md","name":"CVE-2025-10164","record":{"aliases":["GHSA-9w53-xr52-mwgj","PYSEC-2026-1919"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM serving library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via unsafe deserialization in the update_weights_from_tensor function of the sglang library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A security flaw has been discovered in lmsys sglang 0.4.6. Affected by this vulnerability is the function main of the file /update_weights_from_tensor. The manipulation of the argument serialized_named_tensors results in deserialization. The attack can be launched remotely. The exploit has been released to the public and may be exploited. The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"lmsys sglang update_weights_from_tensor main deserialization","id":"CVE-2025-10164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"AP Background \u003c= 3.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2025-10165"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"sglang","purl":null,"source":"GHSA-9w53-xr52-mwgj"},{"ecosystem":"PyPI","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"sglang","purl":"pkg:pypi/sglang","source":"GHSA-9w53-xr52-mwgj"},{"ecosystem":"PyPI","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"sglang","purl":"pkg:pypi/sglang","source":"PYSEC-2026-1919"}],"prev":{"headline":"List Category Posts \u003c= 0.91.0 - Authenticated (Contributor+) SQL Injection via Plugin's Shortcode","id":"CVE-2025-10163"},"products":["sglang"],"published":"2025-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-10","vendors":["lmsys"]},"summary":"Remote attackers can execute arbitrary code via unsafe deserialization in the update_weights_from_tensor function of the sglang library.","url":"https://insights.sbomify.com/CVE-2025-10164/"}