# CVE-2025-10164: lmsys sglang update_weights_from_tensor main deserialization

> Remote attackers can execute arbitrary code via unsafe deserialization in the update_weights_from_tensor function of the sglang library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2025
- **Updated:** 10 Sep 2025
- **Also known as:** GHSA-9w53-xr52-mwgj, PYSEC-2026-1919

## What is CVE-2025-10164?

CVE-2025-10164 is a medium-severity unsafe deserialization vulnerability in lmsys sglang, published on 9 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A security flaw has been discovered in lmsys sglang 0.4.6. Affected by this vulnerability is the function main of the file /update_weights_from_tensor. The manipulation of the argument serialized_named_tensors results in deserialization. The attack can be launched remotely. The exploit has been released to the public and may be exploited. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-10164?

3 open source packages ship an affected version, including sglang.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sglang` | PyPI | All versions | 0.5.4 |
| `sglang` | PyPI | All versions | 0.5.4 |
| `sglang` | PyPI | All versions | 0.5.4 |

## How do I fix CVE-2025-10164?

Upgrade sglang to 0.5.4 or later.

## Is CVE-2025-10164 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10164 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10164 and fix it if it is affected.

What it is: CVE-2025-10164 is a medium-severity unsafe deserialization vulnerability in lmsys sglang, published on 9 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10164 exists.

Affected packages and fixed versions:
- sglang (PyPI): affected all versions; fixed in 0.5.4
- sglang (PyPI): affected all versions; fixed in 0.5.4
- sglang (PyPI): affected all versions; fixed in 0.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10164/ (Markdown: https://insights.sbomify.com/CVE-2025-10164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10164
- OSV: https://osv.dev/vulnerability/CVE-2025-10164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10164/
Summaries are generated and may contain mistakes; the official description above is the record.
